› MySQL 5.5 Community Server
› MySQL 5.6 Community Server
› Percona Configuration Wizard
› XtraBackup 搭建主从复制
Great Sites on MySQL
› Percona
› MySQL Performance Blog
› Severalnines
推荐管理工具
› Sequel Pro
› phpMyAdmin
推荐书目
› MySQL Cookbook
MySQL 相关项目
› MariaDB
› Drizzle
参考文档
› http://mysql-python.sourceforge.net/MySQLdb.html
woi911
V2EX  ›  MySQL

XtraBackup 可以恢复数据库,但备份报错。

  •  
  •   woi911 · Aug 13, 2015 · 3274 views
    This topic created in 4063 days ago, the information mentioned may be changed or developed.

    都是采用rpm 安装的。
    yum -y install perl perl-devel libaio libaio-devel perl-Time-HiRes perl-DBD-MySQL

    centos 6.8 x32 可以正常还原和备份
    rpm -ivh percona-xtrabackup-2.2.12-1.el6.i686.rpm

    innobackupex --database="x" --user=root --password=woi911 --stream=tar ./ | gzip - > /backup/sql-backuped-date +%F__%H-%M.tar.gz

    centos 6.8 x64 可以正常还原,但备份报错。
    rpm -ivh percona-xtrabackup-2.2.12-1.el6.x86_64.rpm

    [code]
    innobackupex --database="x" --user=root --password=woi911 --stream=tar ./ | gzip - > /backup/sql-backuped-date +%F__%H-%M.tar.gz

    InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy
    and Percona LLC and/or its affiliates 2009-2013. All Rights Reserved.

    This software is published under
    the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

    Get the latest version of Percona XtraBackup, documentation, and help resources:
    http://www.percona.com/xb/p

    150813 08:02:15 innobackupex: Executing a version check against the server...
    150813 08:02:15 innobackupex: Connecting to MySQL server with DSN 'dbi:mysql:;mysql_read_default_group=xtrabackup' as 'root' (using password: YES).
    innobackupex: got a fatal error with the following stacktrace: at /usr/bin/innobackupex line 3006
    main::mysql_connect('abort_on_error', 1) called at /usr/bin/innobackupex line 1551
    innobackupex: Error: Failed to connect to MySQL server as DBD::mysql module is not installed at /usr/bin/innobackupex line 3006.
    150813 08:02:15 innobackupex: Connecting to MySQL server with DSN 'dbi:mysql:;mysql_read_default_group=xtrabackup' as 'root' (using password: YES).
    innobackupex: got a fatal error with the following stacktrace: at /usr/bin/innobackupex line 3006
    main::mysql_connect('abort_on_error', 1) called at /usr/bin/innobackupex line 1570
    innobackupex: Error: Failed to connect to MySQL server as DBD::mysql module is not installed at /usr/bin/innobackupex line 3006.
    [/code]

    找了很多资料,percona 官网也看了,还是没找到解决方法。

    1 replies  •  2015-08-14 14:34:21 +08:00
    julyclyde
        1
    julyclyde  
       Aug 14, 2015
    DBD::mysql module is not installed
    About   ·   Help   ·   Advertise   ·   Blog   ·   API   ·   FAQ   ·   Privacy   ·   Solana   ·   2467 Online   Highest 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 24ms · UTC 15:42 · PVG 23:42 · LAX 08:42 · JFK 11:42
    ♥ Do have faith in what you're doing.