› MySQL 5.5 Community Server
› MySQL 5.6 Community Server
› Percona Configuration Wizard
› XtraBackup 搭建主从复制
Great Sites on MySQL
› Percona
› MySQL Performance Blog
› Severalnines
推荐管理工具
› Sequel Pro
› phpMyAdmin
推荐书目
› MySQL Cookbook
MySQL 相关项目
› MariaDB
› Drizzle
参考文档
› http://mysql-python.sourceforge.net/MySQLdb.html
yangwenqian
V2EX  ›  MySQL

1 个用户可以正常工作,但人数大于 5, mysql 数据库就自动关闭了,求帮助!

  •  
  •   yangwenqian · Mar 5, 2016 · 3822 views
    This topic created in 3868 days ago, the information mentioned may be changed or developed.
    以下是错误日志,请问是什么原因导致数据库自动关闭,谢谢。

    160305 1:31:42 [Warning] IP address '121.42.0.16' could not be resolved: Name or service not known
    160305 1:31:42 [Warning] IP address '121.42.0.16' could not be resolved: Name or service not known
    160305 1:44:36 [Warning] IP address '114.215.185.137' could not be resolved: Name or service not known
    160305 9:47:51 [Warning] IP address '121.196.244.10' could not be resolved: Name or service not known
    Killed
    160305 14:55:51 mysqld_safe Number of processes running now: 0
    160305 14:55:51 mysqld_safe mysqld restarted
    160305 14:55:52 [Note] Plugin 'FEDERATED' is disabled.
    160305 14:55:52 InnoDB: The InnoDB memory heap is disabled
    160305 14:55:52 InnoDB: Mutexes and rw_locks use GCC atomic builtins
    160305 14:55:52 InnoDB: Compressed tables use zlib 1.2.3
    160305 14:55:52 InnoDB: Using Linux native AIO
    160305 14:55:52 InnoDB: Initializing buffer pool, size = 128.0M
    InnoDB: mmap(137363456 bytes) failed; errno 12
    160305 14:55:52 InnoDB: Completed initialization of buffer pool
    160305 14:55:52 InnoDB: Fatal error: cannot allocate memory for the buffer pool
    160305 14:55:52 [ERROR] Plugin 'InnoDB' init function returned error.
    160305 14:55:52 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    160305 14:55:52 [ERROR] Unknown/unsupported storage engine: InnoDB
    160305 14:55:52 [ERROR] Aborting

    160305 14:55:52 [Note] /alidata/server/mysql/bin/mysqld: Shutdown complete

    160305 14:55:52 mysqld_safe mysqld from pid file /alidata/server/mysql/data/iZ2892tr3o4Z.pid ended
    2 replies  •  2016-03-06 08:00:45 +08:00
    vibbow
        2
    vibbow  
       Mar 6, 2016
    简单总结一下:内存不足
    About   ·   Help   ·   Advertise   ·   Blog   ·   API   ·   FAQ   ·   Privacy   ·   Solana   ·   2517 Online   Highest 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 25ms · UTC 10:17 · PVG 18:17 · LAX 03:17 · JFK 06:17
    ♥ Do have faith in what you're doing.