› MySQL 5.5 Community Server
› MySQL 5.6 Community Server
› Percona Configuration Wizard
› XtraBackup 搭建主从复制
Great Sites on MySQL
› Percona
› MySQL Performance Blog
› Severalnines
推荐管理工具
› Sequel Pro
› phpMyAdmin
推荐书目
› MySQL Cookbook
MySQL 相关项目
› MariaDB
› Drizzle
参考文档
› http://mysql-python.sourceforge.net/MySQLdb.html
lilifenghao44
V2EX  ›  MySQL

在 arm 手机 chroot 中编译的 mysql 无法启动

  •  
  •   lilifenghao44 · Apr 6, 2017 · 6450 views
    This topic created in 3461 days ago, the information mentioned may be changed or developed.

    环境:用 linux Deploy 软件建立了个 chroot debian. 使用 apt-get 安装 mysql 出现 dpkg 报错 手动编译 mysql,完成,启动报错

    """root@localhost:/home/fanli# /etc/init.d/mysql.server start
    

    Starting MySQL [FAIL....] The server quit without updating PID file (/usr/local/mysql/data/localhost.pid). ... failed!"""

    查看 err 文件

    """2017-04-06 10:30:27 26813 [Note] Plugin 'FEDERATED' is disabled.
    2017-04-06 10:30:27 26813 [Note] InnoDB: Using atomics to ref count buffer pool pages
    2017-04-06 10:30:27 26813 [Note] InnoDB: The InnoDB memory heap is disabled
    2017-04-06 10:30:27 26813 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
    2017-04-06 10:30:27 26813 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrie 2017-04-06 10:30:27 26813 [Note] InnoDB: Compressed tables use zlib 1.2.3
    2017-04-06 10:30:27 26813 [Note] InnoDB: Not using CPU crc32 instructions
    2017-04-06 10:30:27 26813 [Note] InnoDB: Initializing buffer pool, size = 128.0M
    2017-04-06 10:30:27 26813 [Note] InnoDB: Completed initialization of buffer pool
    2017-04-06 10:30:27 26813 [Note] InnoDB: Highest supported file format is Barracuda.
    2017-04-06 10:30:28 26813 [Note] InnoDB: 128 rollback segment(s) are active.
    2017-04-06 10:30:28 26813 [Note] InnoDB: Waiting for purge to start
    2017-04-06 10:30:28 26813 [Note] InnoDB: 5.6.35 started; log sequence number 1625997
    2017-04-06 10:30:28 26813 [Note] Server hostname (bind-address): '*'; port: 3306
    2017-04-06 10:30:28 26813 [Note] IPv6 is not available.
    2017-04-06 10:30:28 26813 [Note] - '0.0.0.0' resolves to '0.0.0.0';
    2017-04-06 10:30:28 26813 [ERROR] Failed to create a socket for IPv4 '0.0.0.0': errno: 13.
    2017-04-06 10:30:28 26813 [ERROR] Can't create IP socket: Permission denied
    2017-04-06 10:30:28 26813 [ERROR] Aborting

    2017-04-06 10:30:28 26813 [Note] Binlog end
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'partition'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_SYS_DATAFILES'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_SYS_TABLESPACES'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN_COLS'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_SYS_FIELDS'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_SYS_COLUMNS'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_SYS_INDEXES'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_SYS_TABLESTATS'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_SYS_TABLES'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_FT_INDEX_TABLE'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_FT_INDEX_CACHE'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_FT_CONFIG'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_FT_BEING_DELETED'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_FT_DELETED'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_FT_DEFAULT_STOPWORD'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_METRICS'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_BUFFER_POOL_STATS'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE_LRU'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX_RESET'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_CMPMEM_RESET'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_CMPMEM'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_CMP_RESET'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_CMP'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_LOCK_WAITS'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_LOCKS'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'INNODB_TRX'
    2017-04-06 10:30:28 26813 [Note] Shutting down plugin 'InnoDB'
    2017-04-06 10:30:28 26813 [Note] InnoDB: FTS optimize thread exiting.
    2017-04-06 10:30:28 26813 [Note] InnoDB: Starting shutdown...
    2017-04-06 10:30:29 26813 [Note] InnoDB: Shutdown completed; log sequence number 1626007
    2017-04-06 10:30:29 26813 [Note] Shutting down plugin 'BLACKHOLE'
    2017-04-06 10:30:29 26813 [Note] Shutting down plugin 'ARCHIVE'
    2017-04-06 10:30:29 26813 [Note] Shutting down plugin 'MRG_MYISAM'

    2017-04-06 10:30:29 26813 [Note] Shutting down plugin 'MyISAM'
    ./data/localhost.err
    """

                                                                                         排版不好见谅.
                                                                                         求解.
    
    9 replies  •  2019-03-09 17:16:32 +08:00
    jtnwm
        1
    jtnwm  
       Apr 6, 2017 via iPhone
    好像没权限,关掉 SELinux 试试。
    lilifenghao44
        2
    lilifenghao44  
    OP
       Apr 6, 2017
    @jtnwm 你好,selinux 状态为 permissive 许可状态.
    manhere
        3
    manhere  
       Apr 6, 2017 via Android
    换个端口试试
    extreme
        4
    extreme  
       Apr 6, 2017   ❤️ 1
    Android 的 Kernel 对用户的网络权限有额外的限制。
    需要把 MySQL 的用户加入用户组 android_inet 。
    kmahyyg
        5
    kmahyyg  
       Apr 6, 2017 via Android
    su
    setenforce 0
    lilifenghao44
        6
    lilifenghao44  
    OP
       Apr 6, 2017
    @manhere apache 都起来了.
    @extreme 是这个问题,加入了 aid_inet 组,成功起来了程序和监听. 非常感谢.
    @kmahyyg selinux 是许可的.
    zhangguanzhang
        7
    zhangguanzhang  
       Apr 8, 2017
    @extreme 感谢层主解决
    seanan
        8
    seanan  
       Apr 8, 2018
    @lilifenghao44
    你好,我也在 Linux DePloy 上装了 Ubuntu
    我也遇到了类似的问题,请问你是怎么解决的呢?
    “加入了 aid_inet 组”是什么意思呢?能详细说一下怎么操作吗?
    另外,我 apache2 也运行不起来。
    lanluosi
        9
    lanluosi  
       Mar 9, 2019
    @seanan
    usermod -a -G aid_net_raw mysql
    加到 aid_net_raw 组就够了
    About   ·   Help   ·   Advertise   ·   Blog   ·   API   ·   FAQ   ·   Privacy   ·   Solana   ·   5473 Online   Highest 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 39ms · UTC 02:36 · PVG 10:36 · LAX 19:36 · JFK 22:36
    ♥ Do have faith in what you're doing.